26 ноября 2017 г.

1C Событие ТЧ копирование и удаление

В 1С нет как такового события копирование строки табличной части, есть
Прошу обратить внимание, речь идет о событиях именно о табличной части (Табличное поле на форме), а не отдельных полей

ПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
//Где параметр Копирование (Булево) определяет скопирована строка или нет
Процедура ТоварыПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
 Если Копирование Тогда
  ПересчитатьСуммуДокумента(); //Пересчитываем сумму табличной части и выводим на форму
 КонецЕсли;
КонецПроцедуры

С удалением строк несколько проще, есть событие ПослеУдаления()

ПослеУдаления(Элемент)
Процедура ТоварыПослеУдаления(Элемент)
 ПересчитатьСуммуДокумента();//Пересчитываем сумму табличной части и выводим на форму
КонецПроцедуры

25 ноября 2017 г.

[1C] Поговорим? или логирование в 1С

Доброго времени всем.

Давно уже воюю с 1Сками, и только сейчас узнал, что помимо всяких журналов можно включить лог. Как это сделать в папке "C:\Program Files\1cv8\8.x.x.xxxx\bin\conf" создаем файлик с именем logconf.xml и пихаем туды содержимое:

 
<config xmlns="http://v8.1c.ru/v8/tech-log">

  <log history="168" location="D:\1C_files\Logs">

    <event>

      <eq property="Name" value="excp">

    </eq></event>

    <property name="all">

    </property>

  </log>

</config>