понедельник, 28 декабря 2015 г.

1С Программно добавляем кнопки на табличное поле

Задача:
Получить ДеревоЗначений из запроса и вывести в ТабличноеПоле. Для некоторых полей добавить кнопки и обработчики событий.
Если бы мы создавали и заполняли табличное поле не программно, то проблем особо не было бы, НО нам нужно программно. Речь пойдет о 8.2 и обычном приложении.

пятница, 18 декабря 2015 г.

Посоветовал знакомому поставить SSD. Он его купил, дал ему флешку с инсталлятором Windows.
Вечером звонок
-Привет, у меня чего то не определяется SSD
-Это сделал, а это, а это? (стандартный пакет вопросов)
-Да, все сделал
-А питание к SSD подключил?
...
Звонит знакомый:
-Включаю твой сервер, сетка заваливается, из 100Мбит выедает больше 90
-Как-нибудь заеду, пока вырубай

Сервер отвечает за бэкап резервного сервера, т.е. инфа обновляется редко и в малых объемах.

Проходит месяца два.
Прихожу, смотрю, да, врубаешь сервак пинг по speedtest падает с 1 до 12-19мс, скорость соответственно тоже.
Открываю консоль, запускаю netstat -tupnc, из активных соединений только openVPN
-Странно, смотри только один, больше нет. А у тебя другого патч-корда нет?
-Есть
-Давай
Втыкаем
-О, другое дело...

суббота, 28 ноября 2015 г.

1С Интерфейс Полный "Такси" и "Все функции"



Не знаю как вам, но мне иногда лень искать, где же закопаны некоторые документы/справочники/отчеты и т.п. в различных интерфейсах 1С (8.2-8.3). Поэтому я использую возможность "Все функции", а интерфейс "Такси" ставлю полный.

1C Интерфейс "Отчет о контактной информации"


Как получить отчет о контактной информации контрагентов?
Для начала нужно понять какую информацию может хранить 1С.
В типовых конфигурациях 1С (здесь описываются конф-ции УП

четверг, 26 ноября 2015 г.

1С Интерфейс Книга покупок/продаж по контрагенту


Налоговая может запросить от Вашего контрагента книгу продаж,  а как сделать такую книгу?, ведь регламентированный отчет не дает выборки (да и не должен). Даже после того, как книги начали формироваться в регламентированном отчете, сами по себе они никуда не исчезли.
Для интерфейса Такси в разделах покупки/продажи есть книги.

среда, 18 ноября 2015 г.

DIY Открытый стенд для ПК из матрицы


Надоело мне размещать залетные материнки на коробках/покладках и т.п., а заталкивать в корпус долго и муторно. Пришла в голову мысль, вот у меня лежат куски оргстекла из матриц, воспользуюсь ими. Увы, имеющиеся оказались малы, может для mini-ATX норм,

воскресенье, 15 ноября 2015 г.

СБИС++ настройка для пользвателя


Как установить СБИС для пользователя с ограниченными правами?
Ничего сложного здесь нет, самое главное - разрешить запись/чтение в папку программы.
По-умолчанию СБИС устанавливается на системный диск (C:).

воскресенье, 1 ноября 2015 г.

HardWare Canon IP7240 вывод отработанных чернил


Эти фотографии уже встречались ранее, но не было описано как это сделано. На этот раз я напишу, не много, но будет понятно. И возможно кому-то не придется мучится и гадать, а почему он все равно течет?

суббота, 31 октября 2015 г.

HardWare А выкидывать ли?


Что делать если сломался ЖК монитор?
Многие ответят - выкинуть!
А я подумаю.
Основные поломки монитора:
  1. Механическое повреждение - прилетело шампанское
  2. Вышли из строя конденсаторы блока питания (потекли или просто потеряли емкость)
  3. Вышел из строя трансформатор
  4. Перегорели лампы

вторник, 20 октября 2015 г.

1С БП/ЗУП 3.0 Ошибки при/после обновления


После обновления БП (Базовая) до 3.0.42.37, нельзя создать элемент справочника Виды оплат организации. Перечисления Способ оплаты (ТипОплат) недоступны.

среда, 14 октября 2015 г.

PowerShell Автоматическое снятие скриншотов


Задача (корпоративный сектор):
Делать снимки экрана раз в 10 сек в режиме Stealth, и складывать в папку на удаленном ПК
Казалось бы, ничего сложного, найти программу и сказать ей куда скидывать.

воскресенье, 4 октября 2015 г.

Как мы трос тянули

Задача установить камеры по схеме:
Камеры отмечены стрелочками с направлением.
Вроде все просто, смета была рассчитана на коленке (не мной, ну кто не ошибается).
Начали растягивать кабель (FTP cat.5e уличная) в 16 гофре.

четверг, 17 сентября 2015 г.

1С Генератор паролей

Создает пароли необходимой длины и в нужном количестве, и записывает их в файл;

КолвоПаса=0;
ВвестиЧисло(КолвоПаса,"Количество паролей");
ДлинаПаса=0;
ВвестиЧисло(ДлинаПаса,"Длина паролей");

пятница, 11 сентября 2015 г.

пятница, 28 августа 2015 г.

Hardware Epson WorkForce 520 Снять печатающую головку

Достался мне этот девайс за 1000Р, но с проблемой, дюзы забиты. Большую часть удалось прочистить прямо с устройства, но остались такие, что и промывка шприцем не помогла.

пятница, 21 августа 2015 г.

четверг, 20 августа 2015 г.

среда, 19 августа 2015 г.

пятница, 14 августа 2015 г.

OSW7 Downgrade платформы без сноса системы


Я уже рассказывал про переезд серверной ОС с Intel на AMD все получилось достаточно быстро и красиво, затык был только в рэйд массиве.
Сегодня я попытался перенести систему (установлена на SSD) с AMD (какой-то из A6) на Intel (intel e5300). К заметке, мать под Intel`ом не умеет AHCI О_о

вторник, 11 августа 2015 г.

ATC OS7070 План работы + AA + Transfer Table

Никогда не думал что найти информацию о такой важной части в настройке АТС сложно. И все таки нашел упоминание - план работы похож на матрёшку ...

четверг, 6 августа 2015 г.

среда, 5 августа 2015 г.

АТС OS7070 Настройка отбоя

Как странно, вроде трубку повесил, а линия занята...
Проходит минута, а линия занята...
Проходит две, три, четыре, а линия все занята....
О, отпустило.
Здесь я расскажу как настраивал программный отбой на АТС OS7070

суббота, 1 августа 2015 г.

1C УТ Ошибка при сохранении данных пользователя ИБ


При попытке создания пользователя ИБ из 1СПредприятие, получил вот такую ошибку:

Ошибка при сохранении данных пользователя ИБ.  Ошибка при вызове метода контекста (Записать): П

четверг, 30 июля 2015 г.

OSW7 Восстановление системы ноутбука с резервного раздела


Сейчас у большинства ноутбуков на ЖД есть скрытый раздел с названием Recovery (или как-то так).
У части ноутбуков при запуске можно увидеть подсказку:
Press F1~F12 for recovery

среда, 29 июля 2015 г.

вторник, 28 июля 2015 г.

Mach3 LPT PCI-e

Попросили собрать новый ПК для работы с фрезерным аппаратом, который подключается через LPT.
Я спросил какую  ОС ставить, ну как обычно ХР. Пошел искать, да с LPT мать сложно найти, решил использовать PCI контроллер.

понедельник, 27 июля 2015 г.

1С Открыть форму выбора с отбором ОП8.2/УП8.3


 Процедура СчетНаОплатуНачалоВыбора(Элемент, СтандартнаяОбработка)
  //Запрет на открытие стандартного окна
  СтандартнаяОбработка=Ложь;
  //Получаем форму отбора документа
  ФормаВыбора=Документы.СчетНаОплатуПокупателю.ПолучитьФормуВыбора(,Элемент); 
  //Устанавливаем режим выбора
  ФормаВыбора.РежимВыбора=Истина;
  //Устанавливаем отбор
  //Если не знаем как называется, ставим точку останова, и смотрим состав ФормаВыбора.Отбор
  ФормаВыбора.отбор.Контрагент.Установить(ЭтотОбъект.Контрагент.Ссылка,Истина);
  ФормаВыбора.отбор.ДоговорКонтрагента.Установить(ЭтотОбъект.ДоговорКонтрагента,Истина);
  //Открываем форму выбора
  ФормаВыбора.Открыть();
 КонецПроцедуры
Открыть форму выбора договора контрагента с отбором по контрагенту (поставщик) и видом договора с поставщиком. Прошу отметить, процедура выполняется на клиенте

&НаКлиенте
Процедура ВидДоговорПоставщикаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
 СтандартнаяОбработка=Ложь;
 Если ЗначениеЗаполнено(ЭтаФорма.Поставщик) Тогда
  ФормаВыбора=ОткрытьФорму("Справочник.ДоговорыКонтрагентов.ФормаСписка");
  ОтборВладелец=ФормаВыбора.Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
  ОтборВладелец.ВидСравнения=ВидСравненияКомпоновкиДанных.Равно;
  ОтборВладелец.Использование=Истина;
  ОтборВладелец.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("Владелец");
  ОтборВладелец.ПравоеЗначение=ЭтаФорма.Поставщик;
  
  ОтборВид=ФормаВыбора.Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
  ОтборВид.ВидСравнения=ВидСравненияКомпоновкиДанных.Равно;
  ОтборВид.Использование=Истина;
  ОтборВид.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("ВидДоговора");
  ОтборВид.ПравоеЗначение=ПредопределенноеЗначение("Перечисление.ВидыДоговоровКонтрагентов.СПоставщиком");

 Иначе 
  ВыводПредупреждения("Не выбран контрагент!!!");
  Возврат;
 КонецЕсли;
КонецПроцедуры

пятница, 24 июля 2015 г.

понедельник, 20 июля 2015 г.

DIY Восстановление корпуса (разные)

Чаще всего у ноутбуков выламывается петля из корпуса. Как решить такую проблему?
Если петля цела, то под кат, если нет покупаем новую и потом под кат, либо изыскиваем другой способ...

КонсультантПлюс Обновление

Для обновления КонсультантПлюс, запустите его с ключом /adm.
CONS.EXE /adm

В разделе сервис выберете "Операции с ИБ"
В открывшемся выберете через интернет.
ОК.
Идем пить чай, берем большую кружку, Консультант, как и СБИС , "ни куда не тороппиттся"...

Далее нужно получить файл *.usr
CONS.EXE /adm /usr /base*

Все :-)

DIY Забавные решения

Здесь буду выкладывать фотки забавных решений проблем.
Термоусадочные трубки можно использовать и с эстетической целью... (наушники sennheiser поврежден на разветвлении провод, оторвал перепаял)

DIY Серверная стойка почти своими руками

Работал раньше в немаленькой организации, была даже "серверная"/кабинет сисадмина:

суббота, 11 июля 2015 г.

1С УТ 10.3 (Обычное приложение) создать кнопку "Новый счет договор"

В конфигурации УТ 10.3 нет кнопки новый счет договор как в конфигурации БП 2.0/3.0
Все приведенное ниже создавалось и проверялось на "Управление торговлей", редакция 10.3 (10.3.31.3)
Ниже представлен кусок кода, который добавляет такой функционал.
Для его использования необходимо создать кнопку на форме и привязать ее к процедуре "НовыйСДНажатие"


пятница, 10 июля 2015 г.

ATC OS7070 Блог ravenich'а: OfficeServ 7070 AA


Столкнулся тут на работе с затыкой. Нужно было заменить сообщение AA на АТС Samsung OfficeServ 7070. Мануала по этому делу естественно ни оказалось, гугление дельной информации не дало. Пришлось потратить два вечера на решение проблемы. В итоге путем перебора кодировок и параметров файлов сообщений на АТС нашли режим в котором GoldWave открыл файл с расширением 711.
Режим таков:
File type: Dialogic (vox);
Attributes: µ-Law 8000 Hz, 64 kbps, mono.
Отлично, узнали, теперь берем запись , которую нужно повесить на сообщение, редактируем, обрезаем и сохраняем.
Настройки такие (что логично):
File type: Dialogic (*.vox)
Attributes: µ-Law 8000 Hz, 64 kbps, mono.
Переименовываем файл (в моем случае 5149.711). Заходим Internet Explorer'ом на web-интерфейс АТС, находим закладку AA/VM, там находим Voice Studio. Там находим наше сообщение (5149) и жмем "Upload".
Звоним и наслаждаемся:)

Up
мои наблюдения
Для загрузки в АТС с прошивкой 4.82 (а точнее старше 4.64) используем FTP.
Для включения FTP идем в 5.13.11 пишем свой ip.
Заходим на FTP каким-нибудь менеджером admin/samsung
/mnt/nand/os7100/vm/pmt/ru_ru - сюда кидаем файл

Я конвертировал при помощи Gold Wave 5.
Из программы файл выйдет *.vox, файл нужно переименовать вместе с расширением.

среда, 8 июля 2015 г.

EXCEL Найти и покрасить в диапазоне из диапазона(ов)




Все знакомы с условным форматированием?
УФ позволяет форматировать ячейки в зависимости от их значений. Один из вариантов:
Найти в диапазоне все вхождения "БЛА".
Создаем правило для диапазона ($A$1:$A$150) с

вторник, 30 июня 2015 г.

1С получить список просроченных заказов


Процедура ПолучитьДокументыПоСтд()
 СрокОплатыСравнение = 2;// 1 - Неважно 2 - Просрочен (более чем на)
 СрокОтгрузкиСравнение = 1;// 1 - Неважно
 НаличиеРезервов = 3;// 1 - Неважно 3 - С резервами
 РазмещениеРезервов = 1; // 1 - На складах и в заказах
 СостояниеОплаты = 2;// 1 - Неважно 2 - Не оплачен полностью (неоплачен либо оплачен частично)
 СостояниеОтгрузки = 1; // 1 - Неважно
    ДатаНач = НачалоДня(ЭтотОбъект.РекДатаНач);//начало периода отбора месяцназад
 ДатаКон = КонецДня(ЭтотОбъект.РекДатаКон);//конец периода отбора месяцвперед
 ПустаяДата=Дата('00010101');
 ДатаОплаты=НачалоДня(ТекущаяДата());
 ДатаОтгрузки=НачалоДня(ТекущаяДата());
 ПричинаЗакрытияЗаказа = Справочники.ПричиныЗакрытияЗаказов.ПустаяСсылка();
 //сообщить(""+ДатаНач+" "+ДатаКон+"");

1С получить список учетных записей электронной почты по пользователю


//Отправитель - СправочникСсылка.Пользователи
//УчетнаяЗапись - Реквизит формы
//Подпись -  - Реквизит формы
//Результат выполнения - последняя итерация цикла
Функция НайтиУЗЗапросом(Отправитель)
  НайтиУчетнуюЗапись=Новый Запрос;
  НайтиУчетнуюЗапись.Текст="ВЫБРАТЬ
                           | УчетныеЗаписиЭлектроннойПочты.Ссылка
                           |ИЗ
                           | Справочник.УчетныеЗаписиЭлектроннойПочты КАК УчетныеЗаписиЭлектроннойПочты
                           |ГДЕ
                           | УчетныеЗаписиЭлектроннойПочты.ДоступКУчетнойЗаписи.Пользователь = &Пользователь"; 
  НайтиУчетнуюЗапись.УстановитьПараметр("Пользователь",Отправитель);
  СписокУЗ=НайтиУчетнуюЗапись.Выполнить().Выбрать();
  Если СписокУЗ.Количество()>0 Тогда
   Сообщить(СписокУЗ.Количество());
   Пока СписокУЗ.Следующий() Цикл
    УчетнаяЗапись=СписокУЗ.Ссылка;
    Подпись=СписокУЗ.Ссылка.ТекстПодписи;
    КонецЦикла;
  Иначе
   Сообщить("УЗ не найдена!!!!")
  КонецЕсли;
КонецФункции


//Вариант 1С, выдает УЗ по-умолчанию
УчетнаяЗаписьПользователя=УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(СсылкаНаПользователя, "ОсновнаяУчетнаяЗапись");

//Также в 1С есть функция возвращающая список доступных УЗ
//ОбщиеМодули.УправлениеЭлектроннойПочтой.ПолучитьДоступныеУчетныеЗаписи(ТекущийПользователь)
//Сами читаем, и пытаемся понять что оно делает


пятница, 26 июня 2015 г.

1С Вычесть рабочие дни на основе ПК (НеВЗапросе)



//Процедура возвращает массив рабочих дней за два месяца
Процедура ЗапросКалендаря()
 ЗапросКалендаря=Новый Запрос;
 ЗапросКалендаря.Текст="ВЫБРАТЬ
               | РегламентированныйПроизводственныйКалендарь.ДатаКалендаря
               |ИЗ
               | РегистрСведений.РегламентированныйПроизводственныйКалендарь КАК РегламентированныйПроизводственныйКалендарь
               |ГДЕ
               | РегламентированныйПроизводственныйКалендарь.Пятидневка = 1
               | И РегламентированныйПроизводственныйКалендарь.ДатаКалендаря >= &НачалоПериода
      | И РегламентированныйПроизводственныйКалендарь.ДатаКалендаря <= &КонецПериода";
 ЗапросКалендаря.УстановитьПараметр("НачалоПериода",ДобавитьМесяц(ТекущаяДата(),-1)); //НачалоПериода
 ЗапросКалендаря.УстановитьПараметр("КонецПериода",ДобавитьМесяц(ТекущаяДата(),1)); //КонецПериода

  Период=ЗапросКалендаря.Выполнить().Выбрать();
  ДваМесяцаРабочихДней=Новый Массив;
  Пока Период.Следующий() Цикл
   ДваМесяцаРабочихДней.Добавить(Период.ДатаКалендаря);
  КонецЦикла; 
КонецПроцедуры

//Использование
Процедура ПолучитьТриДняНазад()
 ОткатитьНазадНа=3;//3 дня
 Сообщить(НачалоДня(ДваМесяцаРабочихДней[ДваМесяцаРабочихДней.Количество()-ОткатитьНазадНа-1]))
КонецПроцедуры


//Вариант самой 1С (нашел в форме отбора просроченных заказов)
Процедура ДниПросрочки()
 ОткатитьНазадНа=3;//3 дня
 //Пытаемся учитывать только рабочие дни по календарю
 ПолучитьДаты = Новый Запрос;
  ПолучитьДаты.Текст = 
  "ВЫБРАТЬ РАЗРЕШЕННЫЕ
  | РегламентированныйПроизводственныйКалендарь.Год
  |ИЗ
  | РегистрСведений.РегламентированныйПроизводственныйКалендарь КАК РегламентированныйПроизводственныйКалендарь
  |ГДЕ
  | РегламентированныйПроизводственныйКалендарь.ДатаКалендаря МЕЖДУ &НачГода И &КонГода";
  
 ПолучитьДаты.УстановитьПараметр("НачГода",НачалоГода(ТекущаяДата()));
 ПолучитьДаты.УстановитьПараметр("КонГода",КонецГода(ТекущаяДата()));
 
 ПолучилиДаты = ПолучитьДаты.Выполнить();
 Если ПолучилиДаты.Пустой() Тогда
   ТребуемаяДатаОплаты=НачалоДня(ТекущаяДата()-24*60*60*ОткатитьНазадНа);
   //ТребуемаяДатаОтгрузки=НачалоДня(ТекущаяДата()-24*60*60*ОткатитьНазадНа);
  Иначе
   ТребуемаяДатаОплаты=ЗаполнениеДокументов.ОпределитьДату(НачалоДня(ТекущаяДата()),-ОткатитьНазадНа);
   //ТребуемаяДатаОтгрузки=ЗаполнениеДокументов.ОпределитьДату(НачалоДня(ТекущаяДата()),-ОткатитьНазадНа);
 КонецЕсли;
 Сообщить(ТребуемаяДатаОплаты);
КонецПроцедуры


//КалендарныеДни - функция, разберетесь сами
Функция ПолучитьДень(ИсходнаяДата, КоличествоПрибавляемыхДней)
 
 Запрос = Новый Запрос("
 |ВЫБРАТЬ 
 |ДОБАВИТЬКДАТЕ(&ИсходнаяДата, ДЕНЬ, &Количество) как Дата");

 Запрос.УстановитьПараметр("ИсходнаяДата", ИсходнаяДата); 
 Запрос.УстановитьПараметр("Количество", КоличествоПрибавляемыхДней); 
 Возврат Запрос.Выполнить().Выгрузить()[0].Дата; 
КонецФункции 

1С интерактивно нажать кнопку на форме


//Для обычного приложения, работает только на открытой форме. Проверено на платформе 8.2, УТ 10.3
Процедура ИнтерактивноНажатьКнопку(Кнопка, ФормаКнопки) Экспорт
    // Удостоверимся что есть права на нажатие
    // Кнопка
    стрОшибка = "";
    Попытка
        Если Кнопка.Видимость = Ложь Тогда
            стрОшибка = стрОшибка + ", Невидима";
        КонецЕсли;    
    Исключение
    КонецПопытки;    
    Попытка
        Если Кнопка.Доступность = Ложь Тогда
            стрОшибка = стрОшибка + ", Недоступна";
        КонецЕсли;    
    Исключение
    КонецПопытки;    
    Если стрОшибка <> "" Тогда
        стрОшибка = Сред(стрОшибка, 3)+" кнопка, которую требуется нажать";
        ВызватьИсключение(стрОшибка);
    КонецЕсли;    
    
    Если ТипЗнч(Кнопка) = Тип("КнопкаКоманднойПанели") Тогда
        Действие = Кнопка.Действие;
    ИначеЕсли ТипЗнч(Кнопка) = Тип("Кнопка") Тогда    
        Действие = Кнопка.ПолучитьДействие("Нажатие");
    КонецЕсли;    
    буфДействие = ФормаКнопки.ПолучитьДействие("ПриПовторномОткрытии");
    ФормаКнопки.УстановитьДействие("ПриПовторномОткрытии", Действие);
    Попытка
        // собственно вызов нажатия кнопки
        ФормаКнопки.Открыть();
        ФормаКнопки.УстановитьДействие("ПриПовторномОткрытии", буфДействие);
    Исключение    
        ФормаКнопки.УстановитьДействие("ПриПовторномОткрытии", буфДействие);
        ВызватьИсключение;
    КонецПопытки;    
КонецПроцедуры

Процедура ОткрытьИЗапустить()
    ЗакрытиеЗаказаДокумент=документы.ЗакрытиеЗаказовПокупателей.СоздатьДокумент();
    ФормаДокумента=ЗакрытиеЗаказаДокумент.ПолучитьФорму("ФормаДокумента");
    ФормаДокумента.Открыть();
    ИнтерактивноНажатьКнопку(ФормаДокумента.ЭлементыФормы.КоманднаяПанельЗаказы.Кнопки.ПодменюЗаполнить.Кнопки.ДействиеЗаполнить,ФормаДокумента);
КонецПроцедуры

понедельник, 22 июня 2015 г.

Все об 1С: Как в 1с 8 Получить список подчиненных документов

Все об 1С: Как в 1с 8 Получить список подчиненных документов:


Функция ПолучитьСписокПодчиненныхДокументов(ДокументОснование) Экспорт
        
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
                   |    СтруктураПодчиненности.Ссылка
                   |ИЗ
                   |    КритерийОтбора.СвязанныеДокументы(&ЗначениеКритерияОтбора) КАК СтруктураПодчиненности";
    
    Запрос.УстановитьПараметр("ЗначениеКритерияОтбора", ДокументОснование);
    Возврат Запрос.Выполнить().Выгрузить();
    
КонецФункции
//Функция возвращает ТаблицуЗначений
//Обходим ее Для Каждого Из Цикл

понедельник, 15 июня 2015 г.

1С Из двух семерок одна распределенная восьмерка


Картинок не будет, мне лень ;-)

Есть:
Две базы "Бухгалтерский учет 4.5" (7.70.538) - одна для менеджера (заводит продажи), одна для бухгалтера (заводит продажи и покупки)

Задача:

  1. Сделать одну базу БП 2.0/3.0
  2. Перекинуть данные за I-II квартал. 
  3. Сделать так, чтобы бухгалтер и менеджер могли работать с базой "одновременно" (физически они находятся в разных точках города).

воскресенье, 7 июня 2015 г.

пятница, 29 мая 2015 г.

1С Автоматическое обновление Типовых конфигураций 1с

Бодрого времени!

С месяц назад один из моих клиентов кинул мне ссылку на сайт Алексея Карманова, многие из Вас знакомы с работами этого Человека. Ссылка конкретно вела на ... подождите, собираюсь с духом ... на "Обновлятор 1С".
Наверно я в раю....
Различные поделки в этой области не в новинку, например это или ЭТО о_О...
У кого-то ценник задран, у кого-то продукт сырой, или создан под конкретные задачи.

Ну так вот, читаю описание:

  1. Поддержка большинства типовых конфигураций
  2. Сам качает обновки, или не качает ;-)
  3. Поддержка различных релизов платформ (ну кроме 7)
  4. Делает РК базы
  5. Планировщик
  6. Может написать письмишко
  7. БЕСПЛАТНО
Ну и т.д., ух, качаю.
Первая проверка прошла успешно, проверял на релизе 8.2 БП 2, версии думаю не актуальны, аппаратный ключ. Дальше поехали 8.3 БП 3 Базовая программная лицензия...упс...нежданчик случился.
Написал автору...

На прошлой  неделе выходит новая версия, с изменениями:
  1. Поддержка разных платформ в одном пакете (указываем разные шаблоны под каждую таблицу)
    N.B. Используемые версии должны находится в одной папке, я решил проблему при помощи симлинка (mklink /D to from)
  2. Поддержка и аппаратной и программной лицензии, требует разовой настройки
  3. Указание ключей запуска
    При использовании и аппаратных и программных лицензий вылезает окошко
    Отключается просто, в настройках базы указываем доп параметр /UseHwLicenses- для использования программной и /UseHwLicenses+ для аппаратной. Этот ключ можно использовать и в обновляторе
  4. Программа сама определяет последнюю версию платформы
  5. Можно указать папку для обновлений, программа качает обновление 1 раз, и использует его во всех случаях.
И т.д., я описал те изменения, которые меня интересовали. 

Данный продукт меня порадовал, равно как и общение с создателем (не просто же так появились некоторые пункты в истории изменений ;-)  )

пятница, 15 мая 2015 г.

Боооольшой человечек

Детская фантазия меня убивает, особенно если сохранена симметрия

  1. "Это такой специальный инструмент"
  2. Телефон
  3. Тачка
  4. Не знаю что это