воскресенье, 26 ноября 2017 г.

1C Событие ТЧ копирование и удаление

В 1С нет как такового события копирование строки табличной части, есть
Прошу обратить внимание, речь идет о событиях именно о табличной части (Табличное поле на форме), а не отдельных полей

ПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
//Где параметр Копирование (Булево) определяет скопирована строка или нет
Процедура ТоварыПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
 Если Копирование Тогда
  ПересчитатьСуммуДокумента(); //Пересчитываем сумму табличной части и выводим на форму
 КонецЕсли;
КонецПроцедуры

С удалением строк несколько проще, есть событие ПослеУдаления()

ПослеУдаления(Элемент)
Процедура ТоварыПослеУдаления(Элемент)
 ПересчитатьСуммуДокумента();//Пересчитываем сумму табличной части и выводим на форму
КонецПроцедуры

[1C] Поговорим? или логирование в 1С

Доброго времени всем.

Давно уже воюю с 1Сками, и только сейчас узнал, что помимо всяких журналов можно включить лог. Как это сделать в папке "C:\Program Files\1cv8\8.x.x.xxxx\bin\conf" создаем файлик с именем logconf.xml и пихаем туды содержимое:

 
<config xmlns="http://v8.1c.ru/v8/tech-log">

  <log history="168" location="D:\1C_files\Logs">

    <event>

      <eq property="Name" value="excp">

    </eq></event>

    <property name="all">

    </property>

  </log>

</config>




среда, 25 октября 2017 г.

Обход ошибки XMeye «неправильный логин пароль», код 11301, «Incorrect account and password»


С каждым днем все больше внедряются системы видеонаблюдения, в связи с этим системы удешевляются, и появляется оборудование работающее через сервис XMEYE.

четверг, 5 октября 2017 г.

1С добавляем возможность отправки вложения в формате PDF

Доброго времени суток.
Речь пойдет о конфигурациях КА 1.1, БП 2.0, УТ 10.3 и т.п. на обычных формах.

1С умеет отправлять печатные формы документов прямо из программы вложением на почту контрагента, но среди возможных вариантов вложения нету PDFа, эту оплошность можно исправить буквально за 10 минут.

воскресенье, 17 сентября 2017 г.

1C Интересный отбор для журнала документов

Доброго всем времени.

Что-то давно не писал, лень наверное накатила )))

Имеем: Комплексная Автоматизация 1.1.86.1 на платформе 8.3.8.2322
Попросили сделать так, чтобы манагеры видели из банковских документов только ППВходящее.

Принялся решать проблему, изменения в конфигурации должны быть минимальны, ибо мне ее потом обновлять.
Открыл интерфейс "Управление продажами", смотрю, здесь доступен журнал "Банковские документы". Ну все решается просто процедурой ПередОткрытием() с отбором и блокировкой отбора. По желанию добавляем проверку группы пользователя.

четверг, 27 апреля 2017 г.

WISP постоянно рвет соединение

При настройке функции WISP на роутере Zyxel столкнулся с проблемой - рвется связь, хотя сигнал отличный. В качестве провайдера выступает Yota USB WiFi. Как выяснилось нужно указывать диапазон не 20/40, а просто 20 и проблема исчезла.

1C Относительный путь

В статье про печати и подписи я писал что нет относительных путей, я несколько ошибся.
Функция СтрокаСоединенияИнформационнойБазы(); возвращает путь до базы (файловой), а оттуда можно уже отталкиваться )))

понедельник, 17 апреля 2017 г.

1СЗапрос Реквизит параметра составного типа

Задача:
Выполнить выборку доков продаж/покупок по артикулу. На входе элемент справочника Номенклатура. Для получения необходимой инфы целесообразней использовать Хозрасчетный регистр по Субконто, нежели перебирать ТЧ всех документом.
Собственно по элементу справочника я получаю данные, но как их получить по Артикулу элемента переданного в запрос в качестве параметра с составным типом?

WebCSSHTML Панель адреса в тон сайту

Поддерживается в Google Chrome для Android с 2014 года
Все просто. Добавить в head:
<meta name="theme-color" content="#db5945">

понедельник, 10 апреля 2017 г.

1СОшибка перенос данных не удалось произвести подключение к информационной базе

При попытке воспользоваться обработкой (встроенной в БП 3.0) "Перенос данных из информационных баз 1С:Предприяетия 7.7" при помощи прямого подключения, получил ошибку:
"не удалось произвести подключение к информационной базе"
Связано с тем, что у семерки на ПК нет записей в реестре и восьмерка не может выполнить подключение при помощи OLE. Решается запуском семерки от администратора. Либо установкой семерки из инсталлятора.

Обработка находится в "Все функции - Обработки"

пятница, 17 марта 2017 г.

1С ОФ Запрос дополнительных параметров для печатной формы

Порой перед выводом печатной формы документа необходимо ввести дополнительные параметры, которые добавлять в конфигурацию не имеет смысла. В моем случае это была форма М4 с указанием номера автомобиля. Так как сделать запрос?

воскресенье, 5 марта 2017 г.

DIY HP dv6-3070er восстановление корпуса.

Изначальной фотки нету, не сделал.
Не хватает крупного куска корпуса.
Хотел использовать стекловолоконную ткань, но дома запретили это делать. Поэтому был выбран такой вариант - жилы из витой пары без изоляции вплавляем в остатки корпуса и припаиваем друг к другу. Потом каркас заливаем и обрабатываем.

MSError Cobian Backup красный крест

Уже несколько раз сталкивался с красным крестом на иконке программы в области уведомлений. В графическом интерфейсе никакой информации почему именно так. Если открыть Параметры, Общие, Настроить, то увидим следующую картину:

вторник, 10 января 2017 г.

Модернизация L-BOXX 102 Sortimo


Купил летом шур BOSH GSR 10,8-2-LI в коробке с вкладышем 1/2 для L-Boxx 102, б/у-шный в Юлмарте, даже смог продлить гарантию ))). Пока оснастки было не много, носил ее в коробочке из под интеловского ssd диска, сам шур носил в коробке. Понятное дело, картонка быстро обтрепалась, а оснастка начала расти в объеме.