Некоторые картинки не загружаются из РФ и РК, используйте VPN.

четверг, 30 июля 2015 г.

OSW7 Восстановление системы ноутбука с резервного раздела


Сейчас у большинства ноутбуков на ЖД есть скрытый раздел с названием Recovery (или как-то так).
У части ноутбуков при запуске можно увидеть подсказку:
Press F1~F12 for recovery

среда, 29 июля 2015 г.

вторник, 28 июля 2015 г.

Mach3 LPT PCI-e

Попросили собрать новый ПК для работы с фрезерным аппаратом, который подключается через LPT.
Я спросил какую  ОС ставить, ну как обычно ХР. Пошел искать, да с LPT мать сложно найти, решил использовать PCI контроллер.

понедельник, 27 июля 2015 г.

1С Открыть форму выбора с отбором ОП8.2/УП8.3


 Процедура СчетНаОплатуНачалоВыбора(Элемент, СтандартнаяОбработка)
  //Запрет на открытие стандартного окна
  СтандартнаяОбработка=Ложь;
  //Получаем форму отбора документа
  ФормаВыбора=Документы.СчетНаОплатуПокупателю.ПолучитьФормуВыбора(,Элемент); 
  //Устанавливаем режим выбора
  ФормаВыбора.РежимВыбора=Истина;
  //Устанавливаем отбор
  //Если не знаем как называется, ставим точку останова, и смотрим состав ФормаВыбора.Отбор
  ФормаВыбора.отбор.Контрагент.Установить(ЭтотОбъект.Контрагент.Ссылка,Истина);
  ФормаВыбора.отбор.ДоговорКонтрагента.Установить(ЭтотОбъект.ДоговорКонтрагента,Истина);
  //Открываем форму выбора
  ФормаВыбора.Открыть();
 КонецПроцедуры
Открыть форму выбора договора контрагента с отбором по контрагенту (поставщик) и видом договора с поставщиком. Прошу отметить, процедура выполняется на клиенте

&НаКлиенте
Процедура ВидДоговорПоставщикаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
 СтандартнаяОбработка=Ложь;
 Если ЗначениеЗаполнено(ЭтаФорма.Поставщик) Тогда
  ФормаВыбора=ОткрытьФорму("Справочник.ДоговорыКонтрагентов.ФормаСписка");
  ОтборВладелец=ФормаВыбора.Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
  ОтборВладелец.ВидСравнения=ВидСравненияКомпоновкиДанных.Равно;
  ОтборВладелец.Использование=Истина;
  ОтборВладелец.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("Владелец");
  ОтборВладелец.ПравоеЗначение=ЭтаФорма.Поставщик;
  
  ОтборВид=ФормаВыбора.Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
  ОтборВид.ВидСравнения=ВидСравненияКомпоновкиДанных.Равно;
  ОтборВид.Использование=Истина;
  ОтборВид.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("ВидДоговора");
  ОтборВид.ПравоеЗначение=ПредопределенноеЗначение("Перечисление.ВидыДоговоровКонтрагентов.СПоставщиком");

 Иначе 
  ВыводПредупреждения("Не выбран контрагент!!!");
  Возврат;
 КонецЕсли;
КонецПроцедуры

пятница, 24 июля 2015 г.

понедельник, 20 июля 2015 г.

DIY Восстановление корпуса (разные)

Чаще всего у ноутбуков выламывается петля из корпуса. Как решить такую проблему?
Если петля цела, то под кат, если нет покупаем новую и потом под кат, либо изыскиваем другой способ...

КонсультантПлюс Обновление

Для обновления КонсультантПлюс, запустите его с ключом /adm.
CONS.EXE /adm

В разделе сервис выберете "Операции с ИБ"
В открывшемся выберете через интернет.
ОК.
Идем пить чай, берем большую кружку, Консультант, как и СБИС , "ни куда не тороппиттся"...

Далее нужно получить файл *.usr
CONS.EXE /adm /usr /base*

Все :-)

DIY Забавные решения

Здесь буду выкладывать фотки забавных решений проблем.
Термоусадочные трубки можно использовать и с эстетической целью... (наушники sennheiser поврежден на разветвлении провод, оторвал перепаял)

DIY Серверная стойка почти своими руками

Работал раньше в немаленькой организации, была даже "серверная"/кабинет сисадмина:

суббота, 11 июля 2015 г.

1С УТ 10.3 (Обычное приложение) создать кнопку "Новый счет договор"

В конфигурации УТ 10.3 нет кнопки новый счет договор как в конфигурации БП 2.0/3.0
Все приведенное ниже создавалось и проверялось на "Управление торговлей", редакция 10.3 (10.3.31.3)
Ниже представлен кусок кода, который добавляет такой функционал.
Для его использования необходимо создать кнопку на форме и привязать ее к процедуре "НовыйСДНажатие"


пятница, 10 июля 2015 г.

ATC OS7070 Блог ravenich'а: OfficeServ 7070 AA


Столкнулся тут на работе с затыкой. Нужно было заменить сообщение AA на АТС Samsung OfficeServ 7070. Мануала по этому делу естественно ни оказалось, гугление дельной информации не дало. Пришлось потратить два вечера на решение проблемы. В итоге путем перебора кодировок и параметров файлов сообщений на АТС нашли режим в котором GoldWave открыл файл с расширением 711.
Режим таков:
File type: Dialogic (vox);
Attributes: µ-Law 8000 Hz, 64 kbps, mono.
Отлично, узнали, теперь берем запись , которую нужно повесить на сообщение, редактируем, обрезаем и сохраняем.
Настройки такие (что логично):
File type: Dialogic (*.vox)
Attributes: µ-Law 8000 Hz, 64 kbps, mono.
Переименовываем файл (в моем случае 5149.711). Заходим Internet Explorer'ом на web-интерфейс АТС, находим закладку AA/VM, там находим Voice Studio. Там находим наше сообщение (5149) и жмем "Upload".
Звоним и наслаждаемся:)

Up
мои наблюдения
Для загрузки в АТС с прошивкой 4.82 (а точнее старше 4.64) используем FTP.
Для включения FTP идем в 5.13.11 пишем свой ip.
Заходим на FTP каким-нибудь менеджером admin/samsung
/mnt/nand/os7100/vm/pmt/ru_ru - сюда кидаем файл

Я конвертировал при помощи Gold Wave 5.
Из программы файл выйдет *.vox, файл нужно переименовать вместе с расширением.

среда, 8 июля 2015 г.

EXCEL Найти и покрасить в диапазоне из диапазона(ов)




Все знакомы с условным форматированием?
УФ позволяет форматировать ячейки в зависимости от их значений. Один из вариантов:
Найти в диапазоне все вхождения "БЛА".
Создаем правило для диапазона ($A$1:$A$150) с