26 ноября 2017 г.

1C Событие ТЧ копирование и удаление

В 1С нет как такового события копирование строки табличной части, есть
Прошу обратить внимание, речь идет о событиях именно о табличной части (Табличное поле на форме), а не отдельных полей

ПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
//Где параметр Копирование (Булево) определяет скопирована строка или нет
Процедура ТоварыПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
 Если Копирование Тогда
  ПересчитатьСуммуДокумента(); //Пересчитываем сумму табличной части и выводим на форму
 КонецЕсли;
КонецПроцедуры

С удалением строк несколько проще, есть событие ПослеУдаления()

ПослеУдаления(Элемент)
Процедура ТоварыПослеУдаления(Элемент)
 ПересчитатьСуммуДокумента();//Пересчитываем сумму табличной части и выводим на форму
КонецПроцедуры

Комментариев нет:

Отправка комментария