5 декабря 2021 г.

[Microsoft][ODBC Text Driver] The Microsoft Access database engine could not find

Произошла исключительная ситуация (Microsoft OLE DB Provider for ODBC Drivers): [Microsoft][ODBC Text Driver] The Microsoft Access database engine could not find the object 'FA_BTL_DAILY_REPORT 02_12.decode.CSV'. Make sure the object exists and that you spell its name and the path name correctly. If 'FA_BTL_DAILY_REPORT 02_12.decode.CSV' is not a local object, check your network connection or contact the server administrator.

21 ноября 2021 г.

1С Нумерация в запросе (УФ)

На платформе 8.3 появилась давно возможность нумерации строк прямо в запросе, все хорошо, но нумерация идет от 1, а мне нужно было от нуля. Решение оказалось банальным, равно как и сортировка записей во временной таблице:

1С Выделить дробную часть

Функция Дроб(Число)
ДробнаяЧасть=Число-Цел(Число);
Возврат(ДробнаяЧасть)
КонецФункции;
 
 

12 ноября 2021 г.

MSError [Microsoft][Драйвер ODBC Excel] Недопустимое использование Null


Использую драйвер ODBC для загрузки массивных таблиц в БД 1С. Таблица имеет 4 столбца все имеют "Общий" или "Текстовый" формат, но данные в столбцах это число, дата + время, длинное число (номер карты), длинное число (номер телефона). Все данные генерированные. На этапе тестирования я решил изменить дату с 30.12 на 01.11 и получил ошибку в сабже.

9 ноября 2021 г.

Проект #34 RB2011 Ставим антенну от Aorus

 У клиента красиво развел кабель по новому офису, упаковал в шкаф, но оборудование не менялось  и получилось так, что RB2011 с WiFi был установлен в шкаф, из-за  чего сигнал был хуже ожидаемого. Когда пришла жалоба, мой взгляд упал на антенну от gigabyte z490 aorus elite ac

Проект #33 Компактный шкаф видеонаблюдения

Небольшой фотоотчет

Состав шкафа:

  • Регистратор -  DS-H208QA
  • Коммутатор - TP-LINK TL-SF1016D
  • Poe инжектор OSNOVO Midspan-8/P
  • БП UPS 120W SIMPLE БЛОК
  • DTM 1207 аккумулятор 7Ач 12В Delta
Коммутатор один из самых дешевых, идея хорошая, но мне не понравился, хоть и может работать от USB. А вот инжектор охонь, камеры IP, но без Poe, т.к. бюджет, такой вариант позволил красиво запитать камеры 12ю вольтами.

8 сентября 2021 г.

1С ЭтоНовый()

 Функция ЭтоНовыйОбъект(Объект)

Возврат Объект.ДополнительныеСвойства.Свойство("ЭтоНовый")

И Объект.ДополнительныеСвойства.ЭтоНовый;

КонецФункции



или


&НаКлиенте

Функция ЭтоНовый()

Возврат ТекущаяСсылкаНаФайл().Пустая();

КонецФункции

&НаКлиенте

Функция ТекущаяСсылкаНаФайл()

ОбъектФормы = ЭтотОбъект.Объект; // СправочникОбъект

Возврат ОбъектФормы.Ссылка;

КонецФункции