8 сентября 2021 г.

1С ЭтоНовый()

 Функция ЭтоНовыйОбъект(Объект)

Возврат Объект.ДополнительныеСвойства.Свойство("ЭтоНовый")

И Объект.ДополнительныеСвойства.ЭтоНовый;

КонецФункции



или


&НаКлиенте

Функция ЭтоНовый()

Возврат ТекущаяСсылкаНаФайл().Пустая();

КонецФункции

&НаКлиенте

Функция ТекущаяСсылкаНаФайл()

ОбъектФормы = ЭтотОбъект.Объект; // СправочникОбъект

Возврат ОбъектФормы.Ссылка;

КонецФункции


15 августа 2021 г.

СБИС3 Плагин не запускается с 1С через RemoteApp

 Сбис онлайн не работает с подписью без плагина. Я был к плагину равнодушен до момента обязательного перехода на третью версию, т.к. эта версия изначально устанавливалась для всех и порождала кучу процессов (до 5 на пользователя, суммарно около 300Мб ОЗУ). Даже на пользовательском ПК с отдельным администратором это бесило, а представьте что я чувствовал когда был вынужден установить его на терминальный сервер с 10 пользователями. 3 гигабайта ОЗУ из 20 уходило только на СБИС3 плагин, хотя им пользовались от силы 3 человека.

22 марта 2021 г.

1СОшибка Вставьте ключевой носитель (был заменен носитель)

 В какой то момент флеш накопитель с ключами от 100 организаций помер, мне повезло и я успел вытащить ключи, НО идентификатор носителя изменился, из-за этого вылезает ошибка "Вставьте ключевой носитель". 

Для существующих сертификатов проблемы нет, открываем Крипто-Про-Сервис-Просмотреть сертификаты в контейнере-Обзор-Находим сертификат и выбираем его - Далее - установить - да (заменить существующий сертификат?) - ок - готово - ок.

А как быть, если был отправлен запрос на смену сертификата, но он не был установлен?

9 марта 2021 г.

CSoft СПДС не запускается или неизвестная команда

 СПДС от CSoft в Автокаде подгружается через приложения (_appload, файлы mcsEnabler.dbx и mcsLoader.arx), при загрузке автокада должна вылезать портянка СПДС, подтверждающая его загрузку. Зачастую отсутствие загрузки говорит либо о запуске под другим профилем (открываем csaIntegrator и ставим нужный по умолчанию) либо о невозможности загрузки приложения (часто решается выгрузкой и обратной загрузкой)

Если нет меню, то загружаем его через файлы адаптаций (_MENULOAD, файл C:\Program Files\CSoft\СПДС GraphiCS X.0\mX\spds_menu.mnu).

Сегодня я столкнулся с другой забавной ошибкой, портянки нету, меню есть, выгружается/загружается, но все равно попытка вызвать команду говорит о том, что она ему неизвестна. Покрутил и так и эдак, на форуме где то прочитал что такое поведение скорее связано с невозможностью загрузить базу (mcsEnabler.dbx), а я уже и БД MS SQL проверил. Решил переустанавливать и у меня не получилось, после начала деинсталляции окно программы просто закрывалось, а такое поведение говорит нам о поврежденном/отсутствующем файле или кривых настройках безопасности. Также такая картина наблюдается если антивирус рубит процесс на лету, решил отключить антивирус, не помогло, тогда я проверил журнал и увидел помещенный в карантин файл MT.dll. Я его восстановил и о чудо, все заработало, остается вопрос к хозяину, почему файл был модифицирован.

11 февраля 2021 г.

Монтажная коробка для DS-2CD2523G0-IWS

 Оригинальный кронштейн из каталога DS-1280ZJ-DM46 поставляет только под заказ, сроки 1.5 месяца. Понятно что никто ждать столько не собирается. Проблема камеры в том, что вывод кабеля не в центре, поэтому большинство коробок не подходит (кроме промрукав 100*100).

31 января 2021 г.

1С Программно добавить колонку в макет

Заголовок конечно неправильный, но именно так я начал поиск ответа на вопрос - как в добавить дополнительную колонку в счет-фактуре не изменяя макет?



Скажу так - геморрой еще тот, а ответ на вопрос - "ВставитьОбласть()"

1СОшибка ИзменениеИКонтроль Текст модуля для метода изменился

Очень забавная ошибка, т.к. при сохранении конфигурации система о ней не оповещает.

Поэтому, перед тем как применять измененную конфигурацию расширения с использованием аннотации ИзменениеИКонтроль нужно выполнить проверку применения: