четверг, 17 октября 2019 г.

Протяжка кабеля между зданиями


Задача:
Протянуть кабель между двумя зданиями.

Большой шкаф и почти все по уму





Средняя полка для еще одного PoE коммутатора



Розетки криво, но мне уже было влом страдать перфекционизмом.


Разводка питания 16 камер

Снизу старое, сверху новое.
Ошибка в том, что надо было колодки ставить справа, там замок. нагрузка между колодками распределена одинаково на два выхода с БП.

Замена розетки




вторник, 15 октября 2019 г.

На фразу "У меня осталось мало места"

Бригада классических пожарников с огнеметами наперевес спрыгивают из ничего на поверхность жесткого диска и начинают эпическую борьбу с битами за свободное пространство ради пользователя

На фразу "Зайди на мой ПК"

Представился мне молоток из клипа Pink Floyd - The Wall шагающий в сторону ПК пользователя

четверг, 22 августа 2019 г.

Ubuntu 18.04 Шифрованный ISCSI том для бэкапов


Всем бобра.

Был DAS cfi-b8253jdgg на 5 дисков по 4Тб (для NAS WD) в 5 рэйд массиве. Места стало мало (под бэкапы), решили расширить. Купили диски по 6Тб, предел для аппарата, из линейки для датацентров. Такой выбор связан с большой ежедневной нагрузкой во время бэкапа, речь идет не о 20 Гб, а о примерно 150 в сутки с последующим архивированием, а также архивирования 1,5Тб раз в неделю. При попытке перегнать данные на новоиспеченный DAS он просто зависал на смерть, как потом выяснилось проблема была в бракованном диске. Но к этому моменту я понял, что покупать такие диски в такой коробок не имеет смысла, т.к. коробок ограничен портами SATA2, с выходом через USB3.0 и слабым охлаждением (для этих дисков). Плюс невозможность контролировать состояние дисков в автоматическом режиме (Zabbix).
Было принято решение собрать NAS на базе Unix системы.

Конфигурация (делал 2 коробки, цена 1 штука):

  1. Корпус FRACTAL DESIGN Node 304 - 5612 руб
  2. Материнская плата ASRock H370 S1151 MITX H370M-ITX/AC - 7240 руб
  3. Накопитель SSD Patriot PS128GPM280SSDR - 1916 руб
  4. Блок питания AeroCool VX-500 PLUS ATX 500W -1613 руб
  5. Видеокарта MSI PCIE16 GT710 1GB GDDR3 GT 710 1GD3H LP - 2158
  6. Оперативная память Kingston DDR4 4Gb 2666MHz KVR26N19S6/4 RTL PC4-21300 CL19 DIMM 288-pin 1.2В - 1308 руб
  7. Процессор Intel Original Core i3 9100F Soc-1151v2 Box - 6683
  8. Жесткий диск WD Ultrastar DC HC310 HUS726T6TALE6L4, 6Тб - 5 штук

среда, 31 июля 2019 г.

Excel В разных окнах (2010) bat

Внизу листинг кода для командной строки, который правит ветки реестра для открытия книг Excel в разных окнах.
Создан потому что после установки обновлений настройки приходится вбивать заново.
Скопировать, вставить в блокнот, сохранить с расширением bat
Выполнять от администратора

(после первого запуска - сохранить выгруженные файлы)

воскресенье, 7 июля 2019 г.

1CОшибка "код справочника стал неуникальным"

Последнее время чаще стала вылезать ошибка "код справочника стал неуникальным" при обновлении, в принципе особых проблем она не доставляет, но раздражает.
В ручную перебирать справочник очень муторно, поэтому я накидал простенький запрос, который выявляет совпадение кода при разных ссылках (на примере справочника ДоговорыКонтрагентов):


ВЫБРАТЬ
 ДоговорыКонтрагентов.Ссылка,
 ДоговорыКонтрагентов1.Ссылка КАК Ссылка1,
 ДоговорыКонтрагентов.Код,
 ДоговорыКонтрагентов1.Код КАК Код1
ИЗ
 Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов
  ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов1
  ПО ДоговорыКонтрагентов.Код = ДоговорыКонтрагентов1.Код
   И ДоговорыКонтрагентов.Ссылка <> ДоговорыКонтрагентов1.Ссылка


пятница, 5 июля 2019 г.

1С УФ ПоказатьВопрос ПередЗаписью

Встала задача - перед записью документа произвести некоторые проверки и задать вопрос пользователю, в зависимости от ответа - провести документ или нет.

Все бы хорошо, но логика не модальных диалогов приводит нас к тому, что вопрос еще не отвечен, а процедура, вызвавшая ее, уже завершила свою работу.

Есть несколько вариантов решения, один - это замена стандартных команд своими, второй использование дополнительных переменных и повторный вызов процедуры.
В моем случае инициирует все процедура ПередЗаписью() (я делал в расширении, перед):

среда, 29 мая 2019 г.

GPO Приложению Word не удалось отобразить нужный шрифт, так как недостаточно памяти или места на диске

Доброго.

На Windows 10 получили такую ошибку после ввода в домен.
Раскопки показали, что виновата политика изменяющая права доступа к некоторым папкам и веткам реестра:
%SystemRoot%\Fonts
%SystemRoot%\System32\FNTCACHE.DAT
MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts

В нашем случае, восстановить права доступа не удалось, единственное решение - отключение политики и переустановка ОС.

Эта политика создавалась для разрешения пользователям устанавливать шрифты, в последних же релизах ОС Windows 10 эта фича появилась.

При этом на Windows 7 проблема не наблюдается.

Marvell 88SE9230 в Ubuntu не видит диски

Всем доброго.

Купили мы значит агрегат "Контроллер расширения ST-Lab A-520 PCI-E x1, 4 int RAID (SATA600) + 2 ext (SATA600), Ret" на контроллере Marvell 88SE9230 для подключения дополнительных дисков к ПК. ПК находится под управлением ОС Ubuntu 12. В Биосе диски видны, в биосе самого контроллера тоже видны, а вот в Ubuntu нет.
Как выясняется, управлять массивом из под Ubuntu нельзя, только работать с полученным виртуальным устройством или дисками в отдельности при помощи lvm или md. Собственно я и брал его ради последнего, но данный контроллер плохо работает в связке iommu=enable + Ubuntu. Поэтому решение проблемы - отключение iommu в биосе материнской платы.

четверг, 2 мая 2019 г.

Проект #16. Цветные фонарики в окно

Спросили, как выделить здание. Я предложил добавить тепла в окна, через некоторое время пришла в голову такая мсль:

Покупаем банки и матируем их (или уже покупаем матовые):


четверг, 11 апреля 2019 г.

1С Нет документа в структуре подчиненности

Добра.

Попросили к документу Поступление на расчетный счет добавить расшифровку по эквайрингу по счетам на оплату. Все добавил, создает проводки по необходимы счетам, но указанные счета на оплату в структуре подчиненности не имею ссылку на документ поступления...
Пока искал, думал - поседею, оказалось все просто - нужно добавить реквизит ТЧ в Общие-Критерии отбора-СтруктураПодчиненности и все сразу заработало ))))

вторник, 5 марта 2019 г.

MSError Сайт налоговой крашит компьютер (Lsass.exe 0xc0000005)

Всем добра.

Была простая задача - применить сертификат сдачи отчетности к сайту налоговой, но не тут то было, после всех настроек попытка перейти на сайт или пройти последний шаг проверки (защищенное соединение) выдавало сообщение:
Обнаружена критическая неполадка, система будет перезагружена через одну минуту. Сохраните работу сейчас.
В журнале:
Имя сбойного приложения: lsass.exe, версия: 6.1.7601.23915, отметка времени: 0x59b94627
Имя сбойного модуля: unknown, версия: 0.0.0.0, отметка времени 0x00000000
Код исключения: 0xc0000005
Смещение ошибки: 0x0000000000000000
Идентификатор сбойного процесса: 0x25c
Время запуска сбойного приложения: 0x01d4d2bc269b4ed6
Путь сбойного приложения: C:\Windows\system32\lsass.exe
Путь сбойного модуля: unknown
и
Критический системный процесс "C:\Windows\system32\lsass.exe" завершился ошибкой с кодом состояния c0000005.  Необходимо перезагрузить компьютер.

В поисках наткнулся на упоминание крипто-про, который я не так давно обновил при помощи СБИС (только так можно подтянуть лицензию при  переходе с 3 на 4). Там упоминалось решение проблемы в версии 4.0.9845, но она у меня и установлена, обновил до 4.0.9944 - проблема решилась.

воскресенье, 24 февраля 2019 г.

1С [Конвертация] Проверка реквизита (параметра) перед выгрузкой объекта (Организация)

Для выгрузки объектов при помощи КД (для конфигурация на платформе 8.2,8.3), где реквизит удовлетворяет требованиям параметра:

В Конвертация=>Параметры добавляем нужный параметр (Организация), обязательно указываем тип.
В Конвертация=> ПередВыгрузкойОбъекта:


Если Документы.ТипВсеСсылки().СодержитТип(ТипЗнч(Объект)) Тогда

    Если Объект.Метаданные().Реквизиты.Найти("Организация") <> Неопределено И (Параметры.Контрагент <> Объект.Организация) и (ЗначениеЗаполнено(Параметры.Организация)) Тогда

        Отказ = Истина;      

    КонецЕсли;
       
ИначеЕсли Справочники.ТипВсеСсылки().СодержитТип(ТипЗнч(Объект)) Тогда

    Если Параметры.БазоваяВерсия И Объект.Метаданные().Реквизиты.Найти("Организация") <> Неопределено И (Параметры.Организация <> Объект.Организация) и (ЗначениеЗаполнено(Параметры.Организация))  Тогда

        Отказ = Истина;

    КонецЕсли;

КонецЕсли;

Для проверки заполненности параметра:
В Конвертация=>ПередВыгрузкойДанных:

Если Не ЗначениеЗаполнено(Параметры.Организация) Тогда
 Сообщить("Не указана Организация на вкладке Параметры!");
 Сообщить("Выгрузка остановлена");
 Отказ=Истина;
КонецЕсли;

1С [Конвертация] Комментарий ко всем объектам

Конвертация => ПослеЗагрузкиОбъекта:


ЕстьПолеКомментарий=Неопределено;
СправочникГруппа=Ложь;
ЗаполненоПолеКомментарий="";
Попытка
 ЕстьПолеКомментарий=Объект.Метаданные().Реквизиты.Найти("Комментарий");
Исключение
КонецПопытки;
Попытка
 ЗаполненоПолеКомментарий=Объект.Комментарий;
Исключение
КонецПопытки;
Попытка
 СправочникГруппа=Объект.ЭтоГруппа;
Исключение
КонецПопытки;
Если ЕстьПолеКомментарий <> Неопределено И Не СправочникГруппа И ЗаполненоПолеКомментарий="" Тогда
 Объект.Комментарий=Строка("Загружено из другой базы: "+ТекущаяДата());
КонецЕсли

суббота, 12 января 2019 г.