13 декабря 2015 г.

MS 0x800ccc13 outlook 2010/2016

Звонит клиент, говорит письма не уходят из Outlook`a. Присылает фото с кодом ошибки сабжа...

Предыстория.

Изначально клиент обратился со следующей проблемой:
Не работает "Адресат" из контекстного меню проводника. Окошко с предложением сжатия фото вылезает, а дальше не идет.
Никогда не пользовался такой штукой, да и почтовики не люблю использовать. Все это происходит на ноутбуке Lenovo Yoga (один из первых). Офис стоит 2003 и 2013 (х64) с момента покупки. Летом обновился до Win10.
В "Сопоставление типов и протоколов" напротив .mapimail стоит "Почтовая служба" - "Неизвестное приложение". Так и должно быть. Хотя я попробовал указать в качестве приложения Outlook, но это системе не понравилось...
Метод:
Создаем ярлык в папке %appdata%\Microsoft\Windows\SendTo. Ставим путь: "C:\Program Files\Microsoft Office\Office14\OUTLOOK.EXE" /c ipm.note /a
Не подошел, т.к. этот метод не поддерживает несколько вложений, сжатие перед вложением и т.п.
Попробовал восстановить по-быстрому и по-медленному, на что получил:


Попытка удаления привела к такой же ошибке.
Перешел по ссылке, предложили скачать "Устранение неполадок", которое удаляет офис. И тут, выскакивает сообщение о том, что обновление для office 2013 готово, и можно обновиться до 2016. Давай обновимся.
Обновились. Проблема исчезла, я расслабился и пошел домой.

История

Через 20 минут (я в метро) приходит сообщение:
-"Интернет есть?"
-"Есть"
-"Дома попробуйте" (в этот день я выключал шлюз, и у некоторых бывает не настроена выгрузка правил при выключении и восстановление при включении)
-"Сейчас попробую с использованием мобильного интернета"
-"Ок"
-"Тоже не работает"
-"С телефона работает?"
-"Да"
-"Ладно, через 1,5 часа буду дома, посмотрим"

Залез на ноутбук. Проверка настроек учетной записи проходит на ура. Попытка получения/отправки сообщений с разных серверов вызывает ошибку. Проблему сервера отметаем. Клиент к этому моменту удалил 2003 офис. 
Запустил outlook в безопасном режиме (ключ /safe). Проблема не исчезла, зато появилось новая - слетела активация (как ни странно - покупная).
Попытка восстановления привела к ошибке сверху.
Открыл интернеты, и Microsoft говорит, что да, таки такая проблема есть после обновления на Win10 и решение:
sfc /scannow && shutdown -r -t 00 -f
От админа.
Выполнил, были обнаружены ошибки, все исправлено. Но проблему не решило.
Снес Office полностью, установил 2010.
Мало того что потерял профили (до 2013 офиса, профили хранились в Панель управления - Почта (32 бита), после такого нет), так и проблема не решилась.
Снес 2010 офис.
Пошел искать у Microsoft дистрибутив 2013 офиса, бесплатно не нашел, только 2010.
Скачал с торрента Office 2013 Pro Plus (и х86 и х64)
Установил х64 и все заработало.

  1. Лицензия подхватилась
  2. Почта уходит
  3. Профили подцепились
  4. Отправить Адресат работает
Собственно проблема оказалась в том, что ОС обновила х64 х86-тым на 64-битной системе.
На все это ушло около 10 часов (операция удаления зависла на 3 часа, скачивание 5Гб всяких программ через мобилку, сканирование системы тоже не из быстрых)

Соль

Не доверяйте автоматическому обновлению продуктов.

Комментариев нет:

Отправка комментария