27 мая 2020 г.

1С БП расхождение отчетов задолженности и актов сверки

Столкнулся с проблемой при изготовлении отчета на основе отчетов задолженности. Заказчик посмотрел выкладку и говорит, тыкая пальцем, это не те цифры. Открыл акт сверки и показал что цифры различаются.

Если открыть справку отчета, там написано - "Данные отчета аналогичны данным стандартного отчета Анализ субконто по субконто Договор"
Открыли Анализ счета, выбрали интересующий договор и узрели 63 счет, которого не должно быть в наших расчетах и которого нету в акте сверки. Т.к. я делал отчет на основе имеющихся, то пришлось внести коррективы:
В модуле менеджера ПередКомпоновкойМакета():

БухгалтерскиеОтчетыКлиентСервер.УстановитьПараметр(КомпоновщикНастроек, "СчетаСДокументомРасчетов", СчетаУчетаРасчетов.СчетаСДокументомРасчетов);
БухгалтерскиеОтчетыКлиентСервер.УстановитьПараметр(КомпоновщикНастроек, "СчетаБезДокументаРасчетов", СчетаУчетаРасчетов.СчетаБезДокументаРасчетов);

заменил на:
БухгалтерскиеОтчетыКлиентСервер.УстановитьПараметр(КомпоновщикНастроек, "СчетаСДокументомРасчетов", Удалить63(СчетаУчетаРасчетов.СчетаСДокументомРасчетов));
БухгалтерскиеОтчетыКлиентСервер.УстановитьПараметр(КомпоновщикНастроек, "СчетаБезДокументаРасчетов", Удалить63(СчетаУчетаРасчетов.СчетаБезДокументаРасчетов));

И добавил простенькую функцию:

Функция Удалить63(МассивДанных)
	НовыйМассив=Новый Массив;
	Для каждого СтрМас Из МассивДанных Цикл 
		Если СтрМас<>ПланыСчетов.Хозрасчетный.РезервыПоСомнительнымДолгам Тогда
			НовыйМассив.Добавить(СтрМас);
		КонецЕсли;
	КонецЦикла;
	Возврат(НовыйМассив);
КонецФункции

Комментариев нет:

Отправка комментария