24 мая 2020 г.

Excel снять объединение и заполнить пустые ячейки

Есть у вас столбец, в котором все ячейки объединены в одну, и нужно снять объединение заполнив ячейки?, тут все просто - снимаем объединение и протягиваем значение.
А что если в столбце 300К строк, и объединение идет по 3-10 строк с разными значениями? Есть надстройка - платная, а можно использовать 2 дополнительных столбца в 4 шага:

  1. Создать столбцы
  2. Протянуть формулу в одном из столбцов
  3. Скопировать полученный результат в режиме только значения
  4. Удалить лишние столбцы (оригинальный и с формулой)
А какую формулу использовать?
Предположим, что столбец источник - D1:D300000, формулу вставляем в столбец С1:С300000, копируем все B1:B300000
В первой строке используем просто копирование (=D1), а в последующих логика проста:
Если ячейка в текущей в столбце D пустая
тогда текущая ячейка равна предыдущей
иначе текущая ячейка равна ячейке в текущей строке в столбце D

=ЕСЛИ(D2="";B1;D2)

Протягиваем, копируем, удаляем.

Комментариев нет:

Отправка комментария