четверг, 23 декабря 2021 г.

1СОшибка УНФ не сохраняет начальный экран

Завел себе УНФ и не стал заморачиваться с предварительной настройкой, а просто синхронизировал с БП. Убрал начальную страницу настройки в разделе "Настройка начальной страницы", настроил панели под себя... И какого же было мое удивление, когда перезапустив базу я увидел начальную страницу О_О

Подумал может кэш, т.к. галки "завершить настройку" на странице нету. Оказалось - нет, кэш тут не при чем. Пошел копать дальше. Наткнулся на константу "Дата первого запуска", заполнена не была, установка проблему не решила. Полез разбираться, откуда идет вызов, в итоге нашел ОбщиеМодули.ИнформацияПРиЗапуске.ГлобальныеНастройки(). Здесь как раз идет опрос различных частей и устанавливается признак отображения страницы. Почитав код, нашел это:


Если Настройки.Показывать Тогда
	УстановитьПривилегированныйРежим(Истина);
	ЗаписьРегистра = РегистрыСведений.ПакетыИнформацииПриЗапуске.Получить(Новый Структура("Номер", 0));
	ПакетыСтраниц = ЗаписьРегистра.Состав.Получить();
	УстановитьПривилегированныйРежим(Ложь);
	Если ПакетыСтраниц = Неопределено Тогда
		Настройки.Показывать = Ложь;
	Иначе
		Информация = ПодготовитьПакетыСтраницКВыводу(ПакетыСтраниц, НачалоДня(ТекущаяДатаСеанса()));
		Если Информация.ПодготовленныеПакеты.Количество() = 0
			Или Информация.МинимальныйПриоритет = 100 Тогда
			Настройки.Показывать = Ложь;
		КонецЕсли;
	КонецЕсли;
КонецЕсли;

  

Открыл регистр "Пакеты информации при запуске", там только 1с запись со значением "0", установил отличное и получил значение Настройки.Показывать равным Ложь. Проверил - теперь открывается мой внешний вид.

Комментариев нет:

Отправить комментарий